Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [sumo-user] Some ideas and proposals for repeated routes

Hello Harald,
Thanks for your suggestions
a)  I agree that using the same attribute name for two related but subtly different things is adding unnecessary confusion (I fact, confusion was recently observed).
Since the 'period' attribute of flows has a lot of history behind it I'll keep this unchanged.
However, I renamed route attribute period to 'cycleTime' (see https://github.com/eclipse/sumo/issues/7168).

b) Incidentally, I was thinking about the same thing recently and came up with this: https://github.com/eclipse/sumo/issues/7164
For an example. see https://github.com/eclipse/sumo/tree/master/tests/sumo/devices/rerouting/stops/public_transport_implicit_route

c) This is already working with the recent fix: https://github.com/eclipse/sumo/tree/master/tests/sumo/devices/rerouting/stops/public_transport_implicit_route_depot


@Dillip Rout: I generally avoid adding new input definitions as long as the existing ones can be used to achieve the desired results. Also, you may find that there is good reason in keeping the edges/stop-list separate from definition of the vehicles that run these stops (especially, when the departure times of the vehicles are not spaced regularly over the whole day).
In terms of changing ambiguous names, there is a large cost associated with changing things that have been used by many people over many years. The case of route attribute period / cycleTime is special insofar that the feature was added recently and thus will not have been widely adopted yet.
This is not to dismiss thoughts on improvements but rather to point out some of the constraints. Feel free to point out things that are confusing and/or inefficient.

regards,
Jakob



Am Mo., 15. Juni 2020 um 11:03 Uhr schrieb Harald Schaefer <fechsaer@xxxxxxxxx>:
Hello

here are some proposals for enhancing the repeated route stuff:

a) change of attribute names

     In route I would rename period to cycletime (German: Umlaufzeit)

     In flow I would rename period to headway (German: Taktzeit)

b) Can we add the repeat features to trips, if we want to specify only
the stops and not the edges or allow an empty edge list?

c) If I want to simulate a whole day, I need also the links to the depot
in the morning and evening

The definition in the testcase
tests/sumo/rail/tramwayLoop/input_routes.rou.xml old (it has no
intermediate edges)

   <trip id="tram1" depart="01" departLane="best" departSpeed="max"
from="Tdepot_1" to="Tdepot_1" type="RB628">
     <stop busStop="leftStop" duration="20"/>
     <stop busStop="rightStop" duration="20"/>
     <stop busStop="leftStop" duration="20"/>
     <stop busStop="rightStop" duration="20"/>
     <stop busStop="leftStop" duration="20"/>
   </trip>

might look in the future

   <route id="startLeft" from="Tdepot_1" to="Tdepot_1" type="RB628">
     <repeat count=2 cycletime=600>
       <stop busStop="leftStop" duration="20"/>
       <stop busStop="rightStop" duration="20"/>
       <stop busStop="leftStop" duration="20"/>
     </repeat>
   </route>
   <flow id="tram1" begin="1" end="300" departLane="best"
departSpeed="max" route="startLeft" headway="120"/>

What do you think?

Greetings,

Harald

_______________________________________________
sumo-user mailing list
sumo-user@xxxxxxxxxxx
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/sumo-user

Back to the top