[
Date Prev][
Date Next][
Thread Prev][
Thread Next][
Date Index][
Thread Index]
[
List Home]
RE: [e4-dev] Project naming convention for junit test projects?
|
Tests in a fragment have the advantage that if
they reproduce the package structure, they can access package-private
members; though I'm not sure to what extent Eclipse uses package-private access
control (I can't relly remember seeing it myself anywhere).
For arguments (2) and (3) I don't really think that
prepending "test." is so special... it seems that any naming convention can be
processed automatically as long as it's consistent (e.g. matching *.test.* in
the bundle name). I also don't think that "sorting tests in the workspace" is
very important, since Working Sets can be used to achieve the
same.
Personally, I'm more in favor of keeping the
"org.eclipse.*" reverse domain notation, such that test bundles/fragments are
"close to" the bundle being tested (I do think that these will often be used /
developed in parallel).
Summing up, I'm in favor of Kevin's / John's second
suggestion: org.eclipse.e4.ui.tests.* / org.eclipse.e4.core.tests.*
etc.
Cheers,
--
Martin Oberhuber, Senior Member of Technical
Staff, Wind River
Target Management Project
Lead, DSDP PMC Member
At a previous project, tests were
1) Always in fragments extending the bundle under test.
2) The fragments were named the same as the bundle, with "test."
prepended. Ie: test.org.eclipse.ui.
3) This made it easy to write a master TestSuite that looked through
the workspace for anything starting with test and automatically running all
tests found therein. No more manually maintaining TestSuite
classes. :-)
Just a thought...
-Dave Orme
On Dec 9, 2008 1:52 PM, "Kevin McGuire" <Kevin_McGuire@xxxxxxxxxx>
wrote:
Hi all,
I added a junit test suite and single test for the
CSS work (it's a start!). As an aside, it's a great use of test-first
programming, since it's helping to prioritize and make concrete the
remaining methods that need to be filled into the CSS support.
Anyhoo the naming I ended up with
was:
org.eclipse.e4.ui.tests.css.swt
which to my mind matches what we did before, like:
org.eclipse.ui.tests.*
However,
I notice we have:
org.eclipse.e4.ui.compatibility.tests
which I think should be:
org.eclipse.e4.ui.tests.compatibility
or maybe more specific while we're at it,
org.eclipse.e4.ui.tests.workbench.compatibility
Thoughts?
Kevin
_______________________________________________
e4-dev
mailing list
e4-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/e4-dev