tycho-packaging:validate-version

Full name:

org.eclipse.tycho:tycho-packaging-plugin:0.21.0:validate-version

Description:

Validates project Maven and OSGi versions. For SNAPSHOT versions, OSGi version qualifier must be ".qualifier" and unqualified Maven and OSGi versions must be equal. For RELEASE versions, OSGi and Maven versions must be equal.

Attributes:

  • Requires a Maven project to be executed.
  • Binds by default to the lifecycle phase: validate.

Optional Parameters

Name Type Since Description
strictVersions boolean - If true (the default) will fail the build if Maven and OSGi project versions do not match. If false will issue a warning but will not fail the build if Maven and OSGi project versions do not match.
Default value is: true.

Parameter Details

strictVersions:

If true (the default) will fail the build if Maven and OSGi project versions do not match. If false will issue a warning but will not fail the build if Maven and OSGi project versions do not match.
  • Type: boolean
  • Required: No
  • Default: true