Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] references
[ATL] references [message #531264] Tue, 04 May 2010 07:23
graa is currently offline graa
Messages: 42
Registered: April 2010
Member
Hello

I made a transformation using an ATL Kaos metamodel that instantiates of SysML that instantiates also of uml .

I want to know if ATL takes into consideration the references?

for example when i execute i have this error message:

Error loading platform:/resource/stage1/test.sysml: The feature 'nd1' is not a valid feature

test.sysml is a source file:

<?xml version="1.0" encoding="UTF-8"?>
<uml:Model xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:kaos="http://www.topcased.org/kaos/1" xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML">
<packagedElement xsi:type="kaos:AbstractGoal" name="g" clientDependency="#//And1 #//And2" />
<packagedElement xsi:type="kaos:ElementryGoal" name="k"/>
<packagedElement xsi:type="kaos:ElementryGoal" name="m"/>
<packagedElement xsi:type="kaos:And" name="And1" supplier="#//k" client="#//g"/>
<packagedElement xsi:type="kaos:And" name="And2" supplier="#//m" client="#//g"/>
</uml:Model>

It not accept "#//",I would like to know if the reference class And (name And1) is known by ATL.

thanks
Previous Topic:Re: I've problems running an ATL M2T transformation from UML
Next Topic:[Xtend] Assign value to Array of EInt
Goto Forum:
  


Current Time: Fri Jul 25 07:20:32 EDT 2014

Powered by FUDForum. Page generated in 0.01465 seconds