EPP FAQ / Known Issues

Running the EPP package XY breaks with an out of memory exception?

There is an error in the Eclipse launcher that prevents setting the correct MaxPermSize automatically to the Java VM launch options. This results in many VM crashes, especially in the large JEE package. See bug 203325 for further information.

As a workaround one can add -XX:MaxPermSize=128m manually to the -vmargs section of the eclipse.ini.

Do the new Eclipse Europa Fall packages contain Eclipse Platform 3.3.0 or 3.3.1?

If you download one of the new Eclipse Europa Fall packages ('eclipse-XXX-europa-fall-YYY') and you open the about dialog, it still shows up with Eclipse version 3.3.0, but it is based on Eclipse Platform 3.3.1. See bug 205020 for further information.

Feature XYZ does not work

Please check the version of your Java Runtime Environment. It is highly recommended to use version 1.5 or higher with the EPP packages! While the Eclipse Platform is known to run with version 1.4, some features of the EPP packages will be disabled silently. See bug 191597 for further information.

Using the Eclipse Update Manager with Eclipse IDE for Java EE Developers

Because of a missing dependency it is not possible to use the Eclipse Update Manager with the 20070628 version of this package. The bug has been reported as bug 194959: Pieces missing from Eclipse IDE for Java EE Developers distribution. Packages downloaded after 2007-07-02 are fixed.

Workaround: Download the fixed package or add the features Data Tools Platform Enablement and Data Tools Platform Documentation manually from the Europa Discovery Update Site.

Eclipse does not start

In some rare environments the Eclipse Packages do not start on Windows. This has been reported in bug 194943 and 194929. Windows packages downloaded after 2007-07-02 do not contain the -Dosgi.bundlefile.limit=100 parameter any more and should work.

Workaround: Download a fixed package or remove the line -Dosgi.bundlefile.limit=100 from the eclipse.ini file.